package.spec 2.5 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. # FIXME: Patch to fix for increased safety
  2. %global build_type_safety_c 0
  3. %global commit 49457116bb0796636fd1bc84f39006fb102bfafc
  4. %global shortcommit %(c=%{commit}; echo ${c:0:7})
  5. %global commitdate 20161025
  6. Name: glimpse
  7. Version: 4.12.6^git%{commitdate}.%{shortcommit}
  8. Release: 4%{?dist}
  9. Summary: Powerful file indexing and query system
  10. License: ISC
  11. URL: https://github.com/gvelez17/glimpse
  12. Source0: %{url}/archive/%{commit}/%{name}-%{commit}.tar.gz
  13. # From Debian
  14. Patch0: fix-makefile.patch
  15. Patch1: fix-makefile-cc-var.patch
  16. Patch2: agrep-fix-double-free.patch
  17. BuildRequires: autoconf
  18. BuildRequires: autoconf-archive
  19. BuildRequires: automake
  20. BuildRequires: flex
  21. BuildRequires: gcc
  22. %if 0%{?rhel} && 0%{?rhel} < 9
  23. BuildRequires: flex-devel
  24. %else
  25. BuildRequires: libfl-static
  26. %endif
  27. BuildRequires: make
  28. Requires: agrep
  29. %description
  30. Glimpse is a very powerful indexing and query system that allows you to
  31. search through all your files very quickly. It can be used by
  32. individuals for their personal file systems as well as by organizations
  33. for large data collections.
  34. %prep
  35. %autosetup -n %{name}-%{commit} -p1
  36. %build
  37. autoconf
  38. %configure
  39. # Parallel make breaks it
  40. make DEBUGFLAGS="%{build_cflags}" OTHERLIBS="%{build_ldflags}"
  41. %install
  42. make install prefix="%{buildroot}%{_prefix}" exec_prefix="%{buildroot}%{_prefix}" manprefix="%{buildroot}%{_mandir}"
  43. # Move undocumented commands to libexec
  44. mkdir -p %{buildroot}%{_libexecdir}/%{name}
  45. mv %{buildroot}%{_bindir}/*cast %{buildroot}%{_bindir}/tbuild %{buildroot}%{_bindir}/wgconvert %{buildroot}%{_libexecdir}/%{name}
  46. # Drop agrep, as we have another provider for it
  47. rm -v %{buildroot}%{_bindir}/agrep %{buildroot}%{_mandir}/man1/agrep.1*
  48. %files
  49. %license LICENSE
  50. %doc README KNOWN_BUGS ChangeLog CHANGES
  51. %{_bindir}/glimpse*
  52. %{_mandir}/man1/glimpse*
  53. %{_libexecdir}/glimpse/
  54. %changelog
  55. * Thu Jul 18 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.12.6^git20161025.4945711-4
  56. - Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
  57. * Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.12.6^git20161025.4945711-3
  58. - Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
  59. * Fri Jan 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 4.12.6^git20161025.4945711-2
  60. - Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
  61. * Tue Dec 12 2023 Neal Gompa <ngompa@fedoraproject.org> - 4.12.6^git20161025.4945711-1
  62. - Initial package